Degraded performance for the Process Street app
Incident Report for Process Street
Resolved
The issue has been resolved.
Posted May 08, 2021 - 18:44 UTC
Investigating
We're currently investigating slow load times affecting the Process Street web application.
Posted May 08, 2021 - 18:19 UTC
This incident affected: Process Street Web Application and Process Street APIs.