Some users are reporting issues to use Microsoft Login

Incident Report for Process Street

Resolved

This incident has been resolved.
Posted Jul 29, 2024 - 21:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2024 - 21:31 UTC

Investigating

We are currently investigating this issue.
Posted Jul 29, 2024 - 21:13 UTC
This incident affected: Process Street Web Application.