We are having issues sending Email notifications

Incident Report for Process Street

Resolved

This incident has been resolved.
Posted May 04, 2023 - 15:43 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 04, 2023 - 13:27 UTC

Investigating

We are currently investigating this issue.
Posted May 04, 2023 - 13:07 UTC
This incident affected: Process Street Web Application and Process Street APIs.