Slack is having an outage and some Slack messages may not be delivered

Incident Report for Process Street

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 11:37 UTC

Monitoring

Your Slack integration may experience problems in Process Street to deliver messages.
Posted Feb 26, 2025 - 16:04 UTC
This incident affected: Process Street Web Application and Process Street APIs.