Some customers are having trouble connecting

Incident Report for Process Street

Resolved

We have a patch that customers that had this issue can apply to fix this problem.
Posted Sep 15, 2021 - 13:27 UTC

Identified

We found a fix that worked in our internal tests, we are testing it with the users that reported this issue now
Posted Sep 14, 2021 - 15:02 UTC

Investigating

Some customers are having problems logging into Process Street. They receive an SSLProtocol error message. Our Engineers are investigating this.
Posted Sep 14, 2021 - 02:44 UTC

Monitoring

We have experienced an unexpected number of requests which have forced us to block some of the traffic. It should be back to normal by now. We will continue to investigate the situation.
Posted Sep 13, 2021 - 18:43 UTC

Investigating

We are currently investigating this issue.
Posted Sep 13, 2021 - 17:17 UTC
This incident affected: Process Street Web Application and Process Street APIs.