Issue sending emails with Send Email widget

Incident Report for Process Street

Resolved

The external provider issue affecting email sending has been resolved.
Posted May 23, 2023 - 20:09 UTC

Monitoring

We are monitoring the external provider.
Posted May 23, 2023 - 19:55 UTC

Identified

We have identified the issue to be with our external email provider. We are monitoring the service's status.
Posted May 23, 2023 - 19:49 UTC

Investigating

We have received reports of issues sending emails via the send email widget and are investigating the issue.
Posted May 23, 2023 - 19:36 UTC
This incident affected: Process Street Web Application.