Upstream Issue Impacting BI Data Source Refreshes

Incident Report for Process Street

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 12:26 UTC

Update

We’ve implemented a fix for the issue impacting BI Data Source updates and have resumed update processing.

We are continuing to monitor closely before marking this incident fully resolved.
Posted Jan 16, 2026 - 10:30 UTC

Identified

We are currently experiencing delays in BI Data Source updates due to an issue with an upstream provider.

This is interrupting our scheduled updates to customer warehouses. We are in contact with the provider and actively working to restore normal update operations as soon as possible.

We will provide updates as more information becomes available.
Posted Jan 16, 2026 - 09:05 UTC
This incident affected: Process Street APIs.