Problems with email delivery (3rd party provider)

Incident Report for Process Street

Resolved

This incident has been resolved.
Posted Oct 25, 2021 - 10:23 UTC

Monitoring

We're experiencing issues with our 3rd party email provider. They are aware of the issue and we're monitoring the situation. In the meantime, new users may not be able to sign up to Process Street.
Posted Oct 25, 2021 - 09:28 UTC
This incident affected: Process Street Web Application.