Major outage for web application, APIs and help site.
Incident Report for Process Street
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 16:28 UTC
Update
The issue has been resolved by our cloud-provider. Our engineers are continuing to monitor the situation.
Posted Dec 15, 2021 - 16:22 UTC
Monitoring
We have identified that this is a result of a larger-scale incident affecting our cloud provider. We’re monitoring the situation as they resolve the issue.
Posted Dec 15, 2021 - 16:18 UTC
Identified
We are receiving reports of customers having issues loading Process Street. Our engineering team is investigating this issue, and we will provide an update as soon as possible.
Posted Dec 15, 2021 - 16:10 UTC
This incident affected: Process Street Web Application and Process Street APIs.